Is it just me?

Discussion in 'Spyderco' started by The Deacon, May 4, 2019.

  1. Wharn

    Wharn Gold Member Gold Member

    Feb 1, 2011
    I use an iPhone and went to settings -> Safari -> clear history and website data and it worked after that
  2. Halfneck


    Jun 30, 2005
    Now I'm getting it using Firefox
  3. Surfingringo

    Surfingringo Gold Member Gold Member

    May 25, 2013
    I just tried that but I am still getting this message. IMG_1070.jpeg
    sliceofaloha likes this.
  4. bdmicarta

    bdmicarta Gold Member Gold Member

    Feb 16, 2012
    I didn't have a problem last night but can't get on tonight using firefox.
    sliceofaloha likes this.
  5. sliceofaloha

    sliceofaloha Gold Member Gold Member

    Oct 4, 2018
    I'm having the same Safari issue now. Security issue and won't allow me to connect.
  6. nickedone


    Nov 8, 2000
    The latest Certificate errors have been brewing for a few years. See the templarbit article below for a brief history. There are other certificate issues as well, for Chrome 70, FF 64/65, Opera, and some other browsers. Some of you may have had a recent crash of add-ons like NoScript, AdBlocker, etc, as well as Avast and other security SW due to certificate problems. (FF fix available for that yesterday)

    Other platforms may (do) still allow access, but more certificate issues are ongoing and incoming, e.g. the MiTM attacks and the DarkMatter Certificate Authority application from the UAE.

    Most of this stuff is deep in the weeds for y'all. You just want to interact with the dang fora.

    Read a little more about it below. As an aside, you can also change settings on FF to allow cert exceptions (as well as for other popular browsers).

    "Google and Mozilla’s distrust of Symantec and sub-brand certificates (GeoTrust, Thawte, VeriSign, Equifax, and RapidSSL) means your users will see a warning page blocking the path to your website when they are using Chrome and Firefox."

    good luck
  7. Wharn

    Wharn Gold Member Gold Member

    Feb 1, 2011

    Weird I’m getting it again now
  8. insta9ves


    Apr 3, 2007
    It’s just an expired ssl cert on the server. Nothing you can do about it on the client side. I’m sure Spyderco will renew their cert in time, and probably put better monitoring/alerting in place to prevent this again. I suggest using this forums for now unless you browse on a computer and can bypass the cert error(not recommended since you may be inputing your username and PW unencrypted).

    Source: do this for a living
    Bill1170 and Wharn like this.
  9. JD Spydo

    JD Spydo Gold Member Gold Member

    Nov 20, 2004
    It's about 7:00am here on Monday the 6th and I'm now starting to get those message/flags and the only way I can get out of it is to go to another website. I'm going to try it on other browsers and see what happens. Heck this has been going on for days now??
  10. jazzz


    Feb 1, 2009
    Same here. I hope they fix it quick.
  11. Don M

    Don M

    Apr 30, 2000
    When this thread was started I wasn't having any problems, but as of last night neither Firefox nor Chrome work on my computer. My phone still gets me there - Android using Chrome. I suspect it is only a matter of time before that doesn't work any more.
  12. jazzz


    Feb 1, 2009
    Nothing works. Please fix, Spyderco techs. Must have forum. :eek:
  13. Sal Glesser

    Sal Glesser Moderator Moderator

    Dec 27, 1998
    Kristi is looking into it.

    ucfgrad93, PStone and Wharn like this.
  14. The Deacon

    The Deacon

    Apr 27, 2003
    Thanks to all who have responded.

    For me anyway, the forum became reachable for a short time yesterday then the error came back and has been back since. Have tried with Firefox, Edge, and Chrome on two separate Windows 10 computers, with no joy. Don't have a smartphone or tablet, and my Linux box died a few months back and I haven't gotten around to replacing it. On the on hand, am glad to know I'm not the only one having this problem, on the other, I'm sorry others are having it too. Guess we just have to wait for someone from Spyderco to fix it.
  15. The Deacon

    The Deacon

    Apr 27, 2003
    Thanks Sal,

    FWIW, here's what it looks like in Firefox on Windows 10

  16. JD Spydo

    JD Spydo Gold Member Gold Member

    Nov 20, 2004
    It's 11:00am where I'm at now and I still can't get on the forum. Not trying to be annoying but just letting everyone know that we still have a problem. I hope it gets fixed soon.
  17. Bill1170


    Dec 20, 2007
    That’s exactly what I did. Unfortunately it didn’t work for me. Still blocked today.
  18. Murphjd25

    Murphjd25 Gold Member Gold Member

    Apr 27, 2016
    It will all be ok...I promise.
    knaf likes this.
  19. sgt1372

    sgt1372 Platinum Member Platinum Member

    Oct 16, 2018
    Can't get into the forums today. Could yesterday but not today. However, the main Spyderco website and login to buy stuff there is unaffected. I use Windows 7 w/Firefox. Doesn't matter much to me because I prefer BF to the Spyderco Forums and seldom log-in there; just read threads when a search takes me there.

    Anyway, FWIW, this is the msg I received today when I attempted bring up the forum login page:

    Secure Connection Failed

    An error occurred during a connection to Peer’s Certificate has been revoked. Error code: SEC_ERROR_REVOKED_CERTIFICATE

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.

    Learn more…

    Report errors like this to help Mozilla identify and block malicious sites
  20. JD Spydo

    JD Spydo Gold Member Gold Member

    Nov 20, 2004
    I hope you're right dude because I'm already going through serious withdrawals :rolleyes::D
    This is even worse than when I gave up booze :D
    Anyone know of a rehab clinic I can check into:eek:????
    Murphjd25 likes this.

Share This Page